CFXII - Black screen with it plugged in

About original Memotech hardware.
User avatar
Dave
Posts: 927
Joined: 11 Aug 2012 18:16
Contact:

Re: CFXII - Black screen with it plugged in

Post by Dave »

No problem, a few red herrings along the way, but you got there in the end.

Hindsight is a wonderful thing, but starting with the simplest working system, then adding complexity as testing progresses is often best. With CFX-II removed, starting with the basic sound problem would likely have revealed the fault much earlier and without the expense of the new Propeller and EPROM as well as the VGA cable.

Still, I’m sure that input was great fun and you will have learned a lot!

Happy MTX/CFX-II ing - again :)

Regards
Dave
User avatar
Dave
Posts: 927
Joined: 11 Aug 2012 18:16
Contact:

Re: CFXII - Black screen with it plugged in

Post by Dave »

Well spotted Martin - I missed that the board appears to have had the timing mod. I was just looking at the original schematics and one of my boards

Regards
Dave
acsi
Posts: 32
Joined: 16 May 2019 08:49

Re: CFXII - Black screen with it plugged in

Post by acsi »

Thanks guys. Yes I've learnt heaps. Especially with the Logic Board today. Also I know understand the CFXII board a lot more.

Also it pushed me to upgrade it :lol:

Yes hindsight is a fantastic thing. I might try putting the old Propeller chip and serial eprom back in to see if they work but that can wait for another day.
User avatar
Dave
Posts: 927
Joined: 11 Aug 2012 18:16
Contact:

Re: CFXII - Black screen with it plugged in

Post by Dave »

If it ain’t broke . . . . . . :D
Post Reply