MTX 512 (debugging thread)

stephen_usher
Posts: 193
Joined: 27 Nov 2016 19:58

Re: MTX 512 (debugging thread)

Post by stephen_usher » 15 Jun 2019 15:43

Indeed, that last method is the preferred if you don't need to save the chip. Far less potential for damaging the PCB!

As for fitting the socket, or at least holding it in place whilst you turn the circuit board upside-down to solder, I use a small bit of double-sided Sellotape, enough to fit between the holes and the same length as the socket. This holds the socket in place securely enough that it doesn't move before you can secure it properly with solder.

User avatar
1024MAK
Posts: 558
Joined: 24 Dec 2012 03:01
Location: Looking forward to summer, in Somerset, UK

Re: MTX 512 (debugging thread)

Post by 1024MAK » 15 Jun 2019 15:54

4116 DRAM chips contain 16384 memory locations. But only one bit wide. Hence in the data sheet it says the chip is a 16384 bit memory. But we need the data width to be 8 bits wide (one byte), so eight DRAM chips are needed, each DRAM chip supplies one bit of the eight bit byte. Total memory will then be 16K bytes (16384 bytes).

4164 DRAM chips contain 65536 memory locations. But only one bit wide. But we need the data width to be 8 bits wide (one byte), so eight DRAM chips are needed, each DRAM chip supplies one bit of the eight bit byte. Total memory will then be 64K bytes.

For reasons of cost, memory manufacturers made available 32768 bit DRAM chips like the 3732H. These cost less than the 65536 bit DRAM chips. But in reality, these are actually 65536 bit DRAM chips where only half the available memory structure inside the chip has been certified as meeting the manufacturers specification. Some of the remaining memory may not function correctly. In other words, they may be partly functional 65536 bit DRAM chips. Because of this, there were actually four different versions of these 32768 bit DRAM chips, as the version sold depended on which sections of memory inside were actually good.

Because of the lower cost, computer manufacturers could use these in place of the 4116 DRAM chips, thus reducing the number of DRAM chips needed. But without the expense of using the much more pricy 4164 DRAM chips. As a bonus, in computers like the Memotech MTX, they could use the same PCB design for both the 32K byte (MTX500) and the 64K byte (MTX512) machines.

With suitable modifications to either the PCB or to the chip, 4164 DRAM chips can be used in place of 4116 DRAM chips. Only one quarter (16K bits) of each of the 4164 DRAM chips will be used. But 4164 DRAM chips use less power compared to 4116 DRAM chips.

Mark

GozdniJezek
Posts: 18
Joined: 07 Jun 2019 20:49

Re: MTX 512 (debugging thread)

Post by GozdniJezek » 23 Jun 2019 13:09

Hello, thank you for the answers and sorry for my late reply, but the time did not permit to continue on this project until now.
So to recap what have I done until now:
1.) I measured the voltages on some of the IC-s that made sense to me (please alert me if i missed something obvious). Please see the picture of the values that i got. All were as expected.
motherboardVoltages.png
motherboardVoltages.png (1.68 MiB) Viewed 267 times
2.) I reverted the machine to the 32k mode, with arranging the LK7 and LK6 to mode 1 from page 48 of the service manual (I have 4000/05 with 32k H Ram Oki chips).
LK.jpg
LK.jpg (3.08 MiB) Viewed 267 times
So the current state is (apologies for the butchery, I'm still waiting for connectors to make a proper jumper):
buchery.jpg
buchery.jpg (308.45 KiB) Viewed 267 times
current output at boot of the machine is:
IMG_20190623_122334.jpg
IMG_20190623_122334.jpg (163.35 KiB) Viewed 267 times
Which to me looks *almost* good :D I've also ordered the 4116 replacements and sockets, It looks like one of the ram Ic-s is bad? I'm planing in shorting the pin 14 with 10ohm resistor, is this the most reliable method or would you suggest something else?
The keyboard input still produces garbage, so my prime suspect is still the ram, however the service manual also mentions:
Corrupt video display or characters
If -5v is absent - check for short at J12
(monitor o/p) of video board - or repair open
circuit. The -5v is generally shorted to 0v at
this point.
3.) If i read correctly J12 is the output of the video board, can someone please tell me how can i check for -5 or what is the expected pinout.
What further actions would you take?
Thank you for your help.
Regards.

User avatar
Dave
Posts: 747
Joined: 11 Aug 2012 18:16
Contact:

Re: MTX 512 (debugging thread)

Post by Dave » 23 Jun 2019 13:13

Hi,

that's progress. Yes, it looks like a VRAM fault, the test to ground the chip through a 10R resistor is a good plan.

As I mentioned before, the corrupt VRAM is more likely to be the cause of the "keyboard" fault than a faulty main RAM. You'll know more once you get the proper display on the screen.

For the reason why, see here http://primrosebank.net/computers/mtx/t ... de_kbd.htm

GozdniJezek
Posts: 18
Joined: 07 Jun 2019 20:49

Re: MTX 512 (debugging thread)

Post by GozdniJezek » 23 Jun 2019 13:24

Thank you for the help. I'll get back with the results (again, it might take a while to get the 4116 and to test the ram).

User avatar
1024MAK
Posts: 558
Joined: 24 Dec 2012 03:01
Location: Looking forward to summer, in Somerset, UK

Re: MTX 512 (debugging thread)

Post by 1024MAK » 23 Jun 2019 14:30

As the supply voltages on the 4116 DRAM chips are present and correct, then a failure of one or two of the 4116 DRAM chips is the most likely cause (assuming there is no PCB track damage).

So I would not worry about looking for a short circuit on J12, as clearly no supplies are in short.

Have we given you tips on the best way of removing soldered in chips?

Mark

GozdniJezek
Posts: 18
Joined: 07 Jun 2019 20:49

Re: MTX 512 (debugging thread)

Post by GozdniJezek » 23 Jun 2019 14:38

--Have we given you tips on the best way of removing soldered in chips?
Yes sir. I don't think i have the tools to try to salvage the IC, neither is there much point in trying to do so.
Thank you.

GozdniJezek
Posts: 18
Joined: 07 Jun 2019 20:49

Re: MTX 512 (debugging thread)

Post by GozdniJezek » 07 Jul 2019 12:17

Hello, it's me again, reporting on progress and "progress".
1.) I managed to replace a faulty 4116 video RAM and i even managed to get it out in one piece. To determine the faulty IC i shorted the pin 14 with an 10 ohm resistor. I've added a socket and a new old stock 4116 (it's from a different supplier but that shouldn't cause a problem right, if one ram is different than the others?)
IMG_20190705_173730.jpg
IMG_20190705_173730.jpg (232.92 KiB) Viewed 207 times
The results were satisfying:
IMG_20190705ready.jpg
IMG_20190705ready.jpg (115.84 KiB) Viewed 207 times
2.) The symptoms after this were:
a.)the keyboard did not work correctly:
--some keys worked ok,
--some keys were dead (nothing happened when pressed),
--some keys registered multiple keystrokes/different keys for example pressing V produced G7 (the keys and results are made up just for illustration purposes), the same key produced different results on each press.
b.) the video would flicker (turn on and off at random-alternate between no video and normal video) - this as to my current understanding is random (would not for example only appear at boot etc...)
3.) Today i wanted to debug the keyboard, and it booted up ok at the begging and after pressing a couple of keys on keyboard i got:
IMG_20190707_pattern.jpg
IMG_20190707_pattern.jpg (177.77 KiB) Viewed 207 times
I'm not sure that key presses did this, but it looked like it. (I don't believe that could be possible) :)
I tried to short all of the video rams again, but there was absolutely no change to the picture.
Could it be that the main ram is causing this, as they are now cold to the touch?
What would you suggest me to do/test next?
As always thank you for the help :)

User avatar
Dave
Posts: 747
Joined: 11 Aug 2012 18:16
Contact:

Re: MTX 512 (debugging thread)

Post by Dave » 07 Jul 2019 17:17

Is the behaviour in the last screen repeatable? i.e., what happened the next time you turned it off/on, was it the same?

Different VRAM chips from different manufacturers are OK, provided that the spec (speed is the same).

Shorting the VRAM (through a resistor) to ground is a good test, but by no means certain to point to the faulty VRAM chip(s). You could still have faulty VRAM based on that last screen.

There could be a keyboard scan/decode problem, but I am not convinced that you have fixed all of the VRAM faults yet. That might become clearer if you can report consistent behaviour, rather than one off events please.

Sticky and/or repeating keys is unfortunately a problem with these mechanical keyboards if they have not been used for a long time. Often, a good dose of "keyboard bashing" will help. If particular keys are really bad, then replacing the key is probably the only option - but only after thoroughly exercising the one that's there. If there is indeed a keyboard problem, then either the drive or sense IC will need replaced (another desoldering job), but let's fully rule out VRAM first. I think it is unlikely to be a main RAM fault at this point

For the video problem, check that wiring to the AV connector on the rear panel and that you have a good connection to the BNC socket. I assume that you are using a BNC to Phono adapter? - I have had problems with intermittent video connection when using cheap adapters.

regards
Dave

Some keyboard info for use in due course
Keyboard general info http://primrosebank.net/computers/mtx/c ... yboard.htm
One Keyboard Issue and its resolution http://primrosebank.net/computers/mtx/r ... arren2.htm

GozdniJezek
Posts: 18
Joined: 07 Jun 2019 20:49

Re: MTX 512 (debugging thread)

Post by GozdniJezek » 07 Jul 2019 18:03

Hello, thank you for the fast answer, yes the problem is reproducible if i turn it on and off again. I will concentrate on finding the next bad VRAM (or multiple of them). Any more tricks in helping to identify it? :)

Regarding the keyboard, i have not yet come to fully debugging it, but the only thing that concerns me a bit are the cases where two letters are either registered or displayed. But this could still just be bad VRAM (hopefully). The other fault could just be the wire from the keyboard to the motherboard. I will concentrate on it more after i get the display in order. And I'll check the reference you posted, thank you.

Regarding the video connection yes I'm using BNC to Phono adapter that came with the computer, I will try to move it a bit next time the picture starts to go, otherwise i'll just replace it with something reputable.

I will report back as soon as i have something new. Thank you for the help.

Post Reply